深度操作系統集成Stable和LTS雙內核,Stable內核為嘗鮮版本,便于用戶體驗高版本內核帶來的新特性,LTS內核則為長期維護版本。

一、系統安裝時選擇不同內核方法

1、在系統安裝啟動器界面,默認選擇LTS版本內核。若通過默認內核安裝不成功,可能是因為部分顯卡兼容性問題導致,可選擇Kernel XX desktop (Safe graphics)內核嘗試。

(啟動界面)

2、若想體驗stable高版本內核,可將選擇區域切換至“Advanced options”,選擇Kernel XX desktop 或Kernel XX desktop (Safe graphics) Stable版本內核進行安裝。

(高級選項)

(Stable內核選項)

二、如何手動安裝雙內核:

深度操作系統內核版本,會以一定周期進行更新,已經安裝系統的用戶,需要安裝最新的內核版本,可通過在[終端]應用中輸入命令行操作。

#安裝LTS內核

sudo?apt?install?linux-image-deepin-amd64?linux-headers-deepin-amd64

#安裝stable內核

sudo?apt?install?linux-image-deepin-stable-amd64?linux-headers-deepin-stable-amd64

安裝舉例:

1、打開[終端]應用,輸入上方對應想要安裝的內核版本命令行,系統自動為你獲取并安裝高版本內核(選擇安裝了Stable內核)。

2、重新啟動計算機進入Advanced options for 20.1 GNU/Linux選項查看,系統啟動高級選項中擁有2個版本內核可選擇。雙內核時系統默認優先選擇高版本內核,如需要啟動低版本內核需要手動選擇啟動。

3、內核可以任意卸載,但是至少要留一個能正常啟動的內核。

a、查詢當前系統已安裝內核并獲取完整包名:dpkg -l | grep "linux-image\|linux-headers"

b、卸載其中一個內核:sudo apt purge linux-image-5.10.18-amd64-desktop linux-headers-5.10.18-amd64-desktop

 

發表評論